Upload problems

Incident Report for Jostle - US

Resolved

This incident has been resolved.
Posted Jan 18, 2026 - 10:33 PST

Identified

We are currently experiencing latency in our file processing system. This may result in failure to upload content in the platform
Posted Jan 16, 2026 - 12:57 PST