Login issues on Firefox
Incident Report for Jostle - US
Resolved
This incident has been resolved.
Posted Nov 29, 2019 - 13:20 PST
Investigating
Our software release 'Question' is causing Login issues on Firefox on Windows OS. We're investigating to fix this problem ASAP. Please use an alternative browser or the Jostle mobile app. We apologize for any inconvenience this may cause and thank you for your patience.
Posted Nov 29, 2019 - 10:40 PST
This incident affected: Login Status.