Jostle's platform is currently unavailable
Incident Report for Jostle - US
Resolved
Jostle's platform is available again.
Posted Jan 13, 2021 - 20:35 PST
Investigating
We are currently investigating and will update status when information is available.
Posted Jan 13, 2021 - 20:24 PST