Jostle's platform is currently unavailable
Incident Report for Jostle - US
Resolved
Jostle's platform is available again.
Posted Jan 15, 2020 - 19:58 PST
Investigating
We are currently investigating and will update status when information is available.
Posted Jan 15, 2020 - 19:57 PST